Compartilhando informação

Arquivo para a categoria ‘Excel’

Fórmula altera cor da célula – excel

Boa noite a todos os leitores

Bom hoje eu vou mostrar um jeito de alterar a cor de fundo da célula usando fórmulas e um objeto de formatação do excel.

ja vi muitos tópicos sobre o assunto e nenhum ensina a fazer ou mostra como se faz, então eu elaborei uma maneira de fazer isso e que fosse fácil.

vamos a prática

este é um exemplo simples mas com um pouco de tempo pode-se aprimorar mais os resultados obtidos, nesse exemplo uso formatação condicional e da pra fazer até 3 comparações

a minha planilha de exemplo ficou assim:

se o total estiver entre 500 e 600 pintará a célula de azul

se o total estiver entre 0 e 499 pintará a célula de vermelho

2.gif

1º O total eu usei uma fórmula simples =b2+c2 … mas pode ser usada qualquer fórmula para seu trabalho

2° Com as ou a CÉLULA selecionada vá ao menu FORMATAR e selecione a opção FORMATAÇÃO CONDICIONAL irá aparecer a tela abaixo:

3.gif

Bom não preciso falar muito pois as imagens são bastantes claras basta apenas um pouco de paciencia e observar o cada coisa faz.

OBS: para funcionar em todas as células faça na primeira célula com a fórmula olhe lá em cima no valor R$ 300,00 e depois clique e arraste para as outras células, ou selecione as células que farão parte da formatação e volte ao passo numero 2.

veja como ficou meu exemplo depois da formatação acima:

4.gif

bom mais pra frente vou melhor essa fórmula e usar com função SE.

Té +

Informática gratuita para você.

Anúncios

Excel – Lista de Funções

Função

Descrição

Sintaxe

AGORA

Determina a hora atual do computador

AGORA( )

DATA

fornece um numero interno para a data especificada

DATA(ano;mês;dia)

DIA

retorna o dia do mes como numero inteiro de 1 a 31
no valor da data

DIA(número)

DIAS

Calcula o numero de dias entre duas datas

DIAS(data_2;data_1)

SEMANAS

Calcula o numero de semanas em um determinado período

SEMANAS

(datainicio;datafinal;tipo)

DESC

Retorna a taxa de desconto de um determinado período

DESC(liquidação;venci

mento;preço;resgate;base)

MOEDADEC

Converte um preço expresso em forma de fração
para decimal

MOEDADEC( moeda

fracionária;fração)

TAXA

Calcula a taxa de juros constantes de um investimento
com pag/regular

TAXA(NPER;PGTO;

VIP;VF;tipo;Estimativa)

N

Coverte um valor para um numero

N(valor)

TIPO

Define o tipo de dados de um valor

TIPO(valor)

E

Retorna verdadeiro caso todos os argumentos sejam
verdadeiros

E(v_logico1;V_logico2)

NÃO

Reverte o valor de um argumento

NÃO(valor lógico)

OU

Retorna verdadeiro se um dos argumetos for verdadeiro

OU(V_logico;V_logico2)

FALSO

define o valor lógico como falso…

FALSO( )

SE

Especifica um teste lógico a ser executado

SE(teste logico;valor se

verdadeiro;valor se falso)

ABS

Retorna o valor absoluto de um numero

ABS(numero)

ARRED

Arredonda um numero com prescisão definida

ARRED(num;contagem)

COMBIN

Calcula o numero de combinações para
elementos sem repetição

COMBIN(num1;num2)

GRAUS

Converte radianos em graus

GRAUS(números)

LOG

Calcula o logaritimo de qualquer base especificada

LOG(num1;base)

EXATO

Especifica se 2 textos são iguais

EXATO(texto1;texto2)

POTÊNCIA

Eleva um numero a potênciad de outro

POTÊNCIA(base;potencia)

RAIZ

Retorna a raiz quadrada de um numero

RAIZ( num1)

SOMA

Retorna a soma de todos os argumentos

SOMA(argumento)

Informática gratuita para você.

Excel – função de arredondamento

Função ARRED

Esta Função arredonda um número até uma quantidade especificada de dígitos, em que você poderá determinar uma Precisão Numérica de “nº” de casas decimais.

=ARRED(célulavariavel;casasdecimais)

Celulavariavel é o número que você deseja arredondar ou a célula onde está o numero

Casasdecimais especifica a quantidade de casas decimais depois da virgula.

=arred(A1;1)

<

p class=”MsoNormal”>Na célulavariavel ou A1 existe um valor igual a 10,999
Na casasdecimais 1
Isso indica que será arredondado para 11

Exemplos

=ARRED(3,35;1) = 3,4 usado 1 casa decimal

=ARRED(3,349;1) = 3,3 usado 1 casa decimal

=ARRED(-3,475;2) = 3,48 usado 2 casas decimais

=ARRED(22,3; -1) = 21 usado -1 casa decimal

no exemplo acima foi usado o valor ao qual seria acrescentada a casa decimal mas poderia usar a célula no lugar do valor ficando assim mais pratico.

Exemplos

=ARRED(A1;1) = 3,4 usado 1 casa decimal

=ARRED(B22;1) = 3,3 usado 1 casa decimal

=ARRED(C33;2) = 3,48 usado 2 casas decimais

=ARRED(D54; -1) = 21 usado -1 casa decimal

Informática gratuita para você.

Excel – Função Soma

Farei um sequencia de post sobre as funções do excel tentarei mostrar como todas elas funcionam.

E hoje será sobre soma o básico do excel.

=soma(a1:a10)

soma os valores das células a1 até a a10

=soma(a1:a10;b1:b10)

soma os valores das células A1 até a A10 e B1 até a B10

Para obtermos a soma das células a1 ate a a10 poderíamos usar a soma

=a1+a2+a3+a4+a5+a6+a7+a8+a9+a10

mas e se o intervalo fosse da a1 até a a500.

Para se montar uma fórmula deve-se observar a regra matemática para as propriedades das operações. Se na fórmula não colocarmos parenteses ( ) o excel irá usar a seguite regra.

1º Potenciação, 2º multiplicação, 3ºdivisão, 4º soma, e por ultimo 5ºsubtração

o exemplo abaixo deixa vem claro

=(2+2)*5 o resultado será 20

=2+2*5 o resultado será 12

quando usamos parenteses este passa a ter prioridade sobre as outras operações

Informática gratuita para você.

Excel- Função de procura

Continuando com os artigos de excel hoje o post vai para uma função muito importante dentro do excel se for usada corretamente

Esta função tem o nome de Procv, procura em banco de dados, bastando apenas que você informe o nome do banco de dados que está em uma planilha do Excel separada.

  1. abra o excel e crie um arquivo novo.

> Renomeia a plan1 para vendas
> Renomeia a plan2 para banco de dados

  1. Na planilha banco de dados monte a seguinte planilha.

procv img1
3. Agora teremos que dar um nome para esse grupo de células, e observe que deixei algumas células a mais para futuras inclusões.

procv img2
4. Depois de Selecionar as células desejadas vá no menu Inserir opção Nome e escolha Definir, e coloque o nome de Consulta e depois clique em adicionar.

  1. Agora iremos criar a página que ira acessar a plan banco de dados. Veja a imagem de como foi montado o meu exemplo.

procv img3

  1. Vamos montar a função que fará a procura do dados na plan banco de dados.

Deixe o espaço produto em branco pois é onde você vai digitar o nome da pessoa que você quer encontrar em seu banco de dados.

começe a fazer a fórmula na frente da célula marca veja imagem.

procv img4
faça a fórmula nas outras células mas observe que você não mudara muita coisa, pois a fórmula será a mesma que você usou mudando somente o numero da coluna de busca da fórmula

A função =procv(c4,’banco de dados’!consulta;2;0)

você está mandando o excel pegar o valor digitado em C4 fazer uma busca pela planilha banco de dados e na tabela que você deu o nome de consulta pegar o valor da coluna 2 e informa que você quer o valor verdadeiro usando 0  se você colocar 1 o resultado será aleatório

para as próximas colunas e só alterar o numero 2 para 3, 4, 5 ate você preencher todas as informações necessárias.

 

Depois que você montou a planilha basta apenas digitar o nome contido no banco de dados e veja o resultado.

procv img5

e isso ai pessoal qualquer duvida pergunte

 

Grt
Davidgois

lista e matérias e exemplos publicados aqui no blog:

Informática gratuita para você.

Excel – papel de parede

O post de hoje é simples com colocar um plano de fundo ou papel de parede no excel e tambem com renomer as planilhas da pasta de trabalho.

Colocando plano de fundo

=> Abra o excel e selecione o menu formatar submenu planilha e opção plano de fundo e agora é só escolher a imagem e clicar em inserir.

Renomeando uma planilha

=> Abra o excel e selecione o menu Formatar submenu planilha e opção renomear e pronto agora basta digitar um nome e apertar enter.

Função SE em excel

Boa noite pessoal

Estou editando este post para melhorar o entendimento do pessoal pois alguns estão tendo dificuldade na interpretação do post.

A função SE faz um teste entre valores determinados e retorna se é VERDADEIRO ou FALSO um exemplo bem simples seria assim:

=SE(2>1,”Maior“,”Menor“)  aqui você determina que o Excel faça a seguinte comparação 2 é maior que 1, se a resposta for VERDADEIRO o Excel retorna MAIOR se for FALSO o Excel retorna MENOR

vamos lá abaixo montei uma planilha para uma turma de alunos onde iremos testar com a função SE, se o aluno esta aprovado ou  reprovado veja imagem abaixo:

1º Passo monte sua planilha.

funcao se img0

2º Passo temos que calcular a média da notas usando a função MEDIA que pega as notas dos 4 bi mestres e divide por 4, certo a fórmula esta na imagem abaixo mas se não conseguir ver a imagem a função e essa: =MEDIA(C5:F5).
Veja que nesta fórmula C5:F5 corresponde as 4 células onde estão as notas dos alunos.

funcao se img1

3º Passo com a média dos alunos agora vamos testar com a FUNÇÃO SE, se o aluno está aprovado ou reprovado a fórmula utilizada e a seguinte:

=SE(H5>=5,D12,D13) aqui testamos se H5 onde está a media do aluno e maior ou igual a 5 depois informamos ao Excel que realize a ação D12 se for VERDADEIRO, senão executa D13 se for FALSO.

D12 e D13 contem as informações que queremos exibir no caso de VERDADEIRO ou FALSO que na nossa planilha está escrito APROVADO ou REPROVADO

mas também poderíamos fazer assim:

=SE(H6>=5,”Aprovado”,”Reprovado”) o resultado aqui e exatamente igual mas com uma diferença nos valores VERDADEIRO ou FALSO escrevemos o que queremos exibir no caso aqui APROVADO ou REPROVADO.

funcao se img2

Até aqui estamos indo bem feito a primeira comparação agora é só arrastar paras as outras células, OPS temos um problema ao fazer isso pois o Excel muda todas as referencias para baixo deixando sua planilha assim:

funcao se img3

e não queremos isso certo, então faça o seguinte quando digitar a fórmula no momento em que você digitar D12 APERTE F4 e tambem ao digitar D13 APERTE F4 isso cria uma referência absoluta para esta duas células não importando quantas linhas você arrastar a formula veja a imagem a seguir com a fórmula corrigida.

funcao se img4

Agora sim já temos um resultado satisfatório veja a imagem abaixo:

funcao se img5

 

Está ai pessoal Função SE revisada e melhorada ai para vocês espero que gostem e até o próximo post.

Grt
DavidGois

Informática gratuita para você.

Informática gratuita

Compartilhando informação

Cartões com Arte

Um novo conceito em cartões. facebook.com/cartoescomarte.

Nouvelle vie au Canada

Casal em busca do seu sonho de morar no Canadá

Informática Gratuita

Compartilhando informação

Red Dreams

Quem disse que meus sonhos não podem ser vermelhos?