Compartilhando informação

Dica da Alene para o blog espero que gostem

Ao invéz de ficar fazendo várias fórmulas SE em uma para obter várias condições de uma vez só vc pode usar apenas a fórmula do “SOMARPRODUTO” essa sim é mamão com açúcar no dia a dia da gente, olha só vou dar um exemplo (vou fazer um exemplo só com 2 condições pra ficar menor a fórmula, mas vc pode colocar qtas condições vc quiser, basta seguir o padrão):

……A………..B………..C…………….D………

1IMÓVEL…..COR……ENDEREÇO……..VALOR
2…CASA………ROSA….RUA BANGU……13.000,00
3…APTº……….ROSA….RUA BRINCO…..15.000,00
4…CASA………AZUL….RUA E…………….20.000,00
5…CASA………ROSA….RUA OURO……..50.000,00

Vamos lá suponhamos que os dados acima seja minha tabela e eu quero comprar todas as “casa” que sejam “rosa”, quanto ficaria pra comprar todas?

eis a fórmula mágica:

=SOMARPRODUTO(–(A2:A5=”CASA”);–(B2:B5=”ROSA”);(D2:D5))

é isso aí, reparem que sempre o último parenteses não começa com “–“, porque? pq a fórmula reconhece “–” antes do “()” como sendo mais uma condição, no caso acima ele vai somar o valor da coluna “D” toda vez que encontrar as condições na coluna “A” e na coluna “B” caso contrário ela nao soma,  para ter mais condições basta vc continuar com a sequência “;–(intervalo_de_linha e a condição)” prontinho.

LEMBRETES IMPORTANTES SOBRE A FÓRMULA:

*** se vc for avaliar valores numéricos não usa-se “” aspas na condição, usa-se somento o numero a ser avaliado.
exemplo:
=SOMARPRODUTO(–(A2:A5=1);–(B2:B5<5);(D2:D5))
neste caso se na coluna “A” for 1 e na coluna B estiver menor que 5 vai somar o valor da col D.

*** se a condição que vc quer varia basta substituir o =”casa” por =B5, assim ela vai procurar o que estiver na célula B5, claro que vc pode mudar pra qualquer outra célula.
exemplo:
=SOMARPRODUTO(–(A2:A5=B5);–(B2:B5<5);(D2:D5))
neste caso se na coluna “A” for igual a célula B5 e na coluna B estiver menor que 5 vai somar o valor da col D.

…lembrando que se vc não quer que a fórmula mude o B5 quando a fórmula for arrastada pra copiar pra outras células tem que add o $ antes do B e antes do 5, ficará assim: $B$5 (essa vale pra qualquer fórmula táh!?)

*** Os intervalos de linhas tem que ser sempre os mesmos.
exemplo:
=SOMARPRODUTO(–(A2:A100=1);–(B2:B100<5);(D2:D100))
se tiver com intervalos diferentes a fórmula vai retornar: #VALOR!
exemplo da fórmula errada:
=SOMARPRODUTO(–(A2:A100=1);–(B2:B100<5);(D2:D112))

É isso aí galerinha, aposto que vai ser muito útil essa fórmula!!!

Informática gratuita para você.

About these ads

Comentários em: "Excel – função somarproduto" (51)

  1. Bruno Teixeira disse:

    A minha dúvida é a mesma do Leandro que ninguém respondeu. Quero saber como somar produto de uma linha com colunas ex: =somarproduto(A1:A5;B1:F1), quem souber favor deixe um comentário..

    Curtir

  2. Bruno Teixeira disse:

    Gente esse somarproduto de casas rosa fica mais fácil no somases Ex =somases(D2:D5;A2:A5,”CASA”;B2:B5;”ROSA”)

    Curtir

  3. RUBEM DE BEM disse:

    NÃO SEI EM QUE LUGAR DIGITAR ESTA FORMULA, EM QUUAL COLUNA OU LINHA?

    Curtir

  4. Boa tarde,

    Preciso realizar SOMARPRODUTO cruzando um intervalo que está numa linha e outro intervalo que está numa coluna com a mesma quantidade, porém está voltando erro.

    Alguma idéia?

    Curtir

  5. CAROLINE NASCIMENTO disse:

    EU PRECISO DE AJUDA TENHO A SEGUINTE PLANILHA

    Aluno Escola Valor Pg
    Rafael CPMG R$ 174,00 X
    Bruna CPMG R$ 150,00 X
    Sharon CPMG R$ 160,00 X
    Nayara CPMG R$ 160,00 X

    PRECISO QUE ELA SOME A CADA VEZ QUE EU DIGITE O “X” IDENTIFICANDO QUE O CLIENTE PAGOU, E ASSIM VÁ SOMANDO E ME DE O VALOR TOTAL DE QUANTO RECEBI DE QUEM TEM O “X’

    ALGUÉM PODE ME AJUDAR PELOO AMOR DE DEUS, TO FICANDO DOIDA JA COM ESSA FORMULA

    Curtir

  6. oi eu tentei reproduzir a planilha do somaproduto usando o seguinte código SOMARPRODUTO((A2:A5=”CASA”);(B2:B5=”ROSA”);(D2:D5)) porem n funciona eu tentei de tudo e n consigo poderia me enviar a planilha para poder analisa-la !

    obs.: uso office 2010

    Curtir

  7. Boa noite pessoal, preciso de uma ajuda..
    como faço para somar um produto ex: Ft001 em varias planilhas diferentes, existe uma formula simples?

    Curtir

  8. E se eu quisesse comprar uma as casas rosas e azul se estivesse mais de duas cores?

    Curtir

  9. Não funcionou, poderia postar a planilha funcional para estudarmos?

    Curtir

  10. Quanto a aparecer cores nas células pode usar a formatação condicional. Quanto a formula de somarproduto, no excel 2010 só funcionou usando o sinal * ao invés de ; conforme abaixo:
    =SOMARPRODUTO((A2:A5=”CASA”)*(B2:B5=”ROSA”)*(D2:D5))

    Curtir

  11. preciso saber a seguinte fórmula:
    se b3 for menor que b2 quero q o valor de uma determinada célula apareça em vermelho,s e não azul.

    Curtir

  12. Márcio,

    Esse comando que todos comentaram aqui só funciona para excel 2003, para versã oaciam de 2007, repita os comandos sem os sinais de menos , da seguinte forma: SOMARPRODUTO((A2:A5=”CASA”);(B2:B5=”ROSA”);(D2:D5))

    Curtir

  13. Alguem pode me ajudar:
    Gostaria de saber como fazer essa formula

    Se A12 FOR MAIOR QUE 360 QUERO SUBTRAIR B2 E SE A12 FOR MENOR QUE zERO(0) SOMAR MAIS B 3

    ALGUEM PODE ME AJUDAR, TO PRECISANDO URGENTE

    Curtir

  14. obrigadooooo

    Curtir

  15. boa noite gostaria de saber se alguem pode me ajudar:
    eu preciso da seguinte formula

    quero somar um valor de uma outra celula caso ela esteja negativo:

    tipo se A1 for menor que 0 somar b25 e se a1 for maior que 360 subtrair b25

    Curtir

  16. boa noite gostaria de saber se alguem pode me ajudar:
    eu preciso da seguinte formula

    quero somar um valor de uma outra celula caso ela esteja negativo:

    tipo se A1 360 subtrair b25

    Curtir

  17. complementando a postagem anterior. A colagem da fórmula somarproduto está corretamente com os sinais “-” duplo, para que a formula funcione corretamente, contudo não funcionou também. Alguém sabe o que poderia estar acontecendo?

    Curtir

    • Márcio,

      Esse comando que todos comentaram aqui só funciona para excel 2003, para versão acima de 2007, repita os comandos sem os sinais de menos , da seguinte forma: SOMARPRODUTO((A2:A5=”CASA”);(B2:B5=”ROSA”);(D2:D5))

      Curtir

  18. Bom dia a todos, a exemplo das formulas somarproduto acima, conforme SOMARPRODUTO(–(A2:A5=”CASA”);–(B2:B5=”ROSA”);(D2:D5)), simplesmente não funciona. Já fiz várias alterações mas a fórmula não deu certo. Não sei como está funcionando para os demais postados. Cheguei a verificar se depende da configuração em VBA análise, e está tudo ok

    Curtir

  19. Excelente! Simples e completo, parabéns!

    Curtir

Gostou Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Cartões com Arte

Um novo conceito em cartões. facebook.com/cartoescomarte.

Nouvelle vie au Canada

Casal em busca do seu sonho de morar no Canadá

Informática Gratuita

Compartilhando informação

Red Dreams

Quem disse que meus sonhos não podem ser vermelhos?

Seguir

Obtenha todo post novo entregue na sua caixa de entrada.

Junte-se a 68 outros seguidores

%d blogueiros gostam disto: